summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-01-02 14:22:47 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-01-02 14:22:47 -0800
commit9e489e45820f59461a897f889d3cb32307166937 (patch)
treed43b279bbccfa1183f8903c754e3478dfca0ee22 /Makefile.am
parent88deaf1f2fdfee347331de6b589a28552d9c3dbd (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b83c9e4..a4c4253 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,9 +34,18 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog autogen.sh
CLEANFILES = $(appman_DATA)
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
SED = sed
# Strings to replace in man pages