summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2017-10-24 13:54:47 -0400
committerAdam Jackson <ajax@redhat.com>2017-10-24 15:14:23 -0400
commit102696da8737fcb324034f673cd5815f28923311 (patch)
tree360e49b700b617768f4289c6d9d23da7641791b1 /Makefile.am
parente12c03d50a634a98e4560c7117a3bec3349561e9 (diff)
Import libXfont's BDF-to-PCF code
bdftopcf is the only consumer of libXfont 1.x's read/write support, and we'd like 1.x to go away entirely. Copy in the BDF read and PCF write support so there's one fewer consumer of 1.x. Signed-off-by: Adam Jackson <ajax@redhat.com> Acked-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index a4f2c74..1265065 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,10 +22,25 @@
SUBDIRS = man
bin_PROGRAMS = bdftopcf
-AM_CFLAGS = $(CWARNFLAGS) @BDFTOPCF_CFLAGS@
-bdftopcf_LDADD = @BDFTOPCF_LIBS@
-
-bdftopcf_SOURCES = bdftopcf.c
+AM_CFLAGS = $(CWARNFLAGS)
+
+bdftopcf_SOURCES = \
+ atom.c \
+ bdfread.c \
+ bdfutils.c \
+ bitmap.c \
+ bitmaputil.c \
+ bufio.c \
+ defaults.c \
+ fileio.c \
+ filewr.c \
+ fontaccel.c \
+ fontink.c \
+ pcfwrite.c \
+ private.c \
+ stubs.h \
+ utilbitmap.c \
+ bdftopcf.c
MAINTAINERCLEANFILES = ChangeLog INSTALL