summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-04-24 20:03:51 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-04-24 20:03:51 -0700
commit7206fb39a668384dfba3c8436222722123f4c9ff (patch)
treeefebf4642de24b55559198e46524f441b5f380b9 /Makefile.am
parentc42df278513724e3236eecda859f069c34f78508 (diff)
Add target for checking code with sparse/lint/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a7e88be..0db86a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,3 +63,11 @@ ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(bdftopcf_CFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(bdftopcf_SOURCES)
+endif LINT