summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-04-24 20:01:40 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-04-24 20:01:40 -0700
commitc42df278513724e3236eecda859f069c34f78508 (patch)
tree2db558cd13e3d03ae57047c60545e21ea8872c79 /Makefile.am
parent608915a471c5a7a1cc3ecca19fc1b516480f439f (diff)
Replace static ChangeLog with disthook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 575c277..a7e88be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog
CLEANFILES = $(appman_DATA)
SED = sed
@@ -58,3 +58,8 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog