summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-01-23 13:42:01 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-01-23 13:42:01 -0800
commit4d02bf25b4e64d0a3fb2270491d3dbe4fc18effc (patch)
tree19690e8b8ae5fa4ef585ddaa5d66984685cdc0c0 /Makefile.am
parent2c5045d72ee4120c52cfc7e008237a438a1c2d30 (diff)
Replace static changelog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 76f7d8d..5960114 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,8 +78,14 @@ SUFFIXES = .ad
appdefault_DATA = $(APPDEFAULTFILES)
-EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) bitmap.icon
+EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) bitmap.icon ChangeLog autogen.sh
CLEANFILES = $(APPDEFAULTFILES)
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
# bitmaps