summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2011-12-20 21:47:56 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-12-20 21:48:09 -0800
commit67ab447959b62454f4e0273177baa19711babb96 (patch)
treef0a0a7c4bdad446a6311d65d18d19a2e534db81a /Makefile.am
parent1c2b70d13c42f5461a2d7c3cae7adf8d9b2e3cea (diff)
Use lrint() from math library if available
Moves -lm from being hardcoded in Makefile.am to being added via AC_SEARCH_LIBS in configure.ac setting it in $(MATH_LIBS) Using lrint() [returns long int] instead of rint() [returns double] clears a bunch of gcc warnings of the form: "cast from function call of type ‘double’ to non-matching type ‘short int’" Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a5ca35..88cc611 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ SUBDIRS=man
bin_PROGRAMS = bitmap bmtoa atobm
bitmap_CFLAGS = $(CWARNFLAGS) $(BITMAP_CFLAGS)
-bitmap_LDADD = $(BITMAP_LIBS) -lm
+bitmap_LDADD = $(BITMAP_LIBS) $(MATH_LIBS)
bitmap_SOURCES = \
BitEdit.c \
CutPaste.c \