summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 15:47:38 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 15:47:38 +0000
commitc6129c090ad25cd2f8b191f503ac6e8cd452a31d (patch)
treeab0c9808a4dff6811b466b13afc75528c2fbf635 /Makefile.am
parent9b6257bdb5461131e42a3d81330c76d7a2bc670a (diff)
Build system for bitmap
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am98
1 files changed, 98 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a71b490
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,98 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = bitmap bmtoa atobm
+
+# bitmap
+
+bitmap_CFLAGS = $(BITMAP_CFLAGS)
+bitmap_LDADD = $(BITMAP_LIBS) -lm
+
+bitmap_SOURCES = \
+ BitEdit.c \
+ CutPaste.c \
+ Graphics.c \
+ ReqMach.c \
+ Bitmap.c \
+ Dialog.c \
+ Handlers.c \
+ Bitmap.h \
+ BitmapP.h \
+ Dialog.h \
+ Requests.h
+
+# bmtoa
+
+bmtoa_CFLAGS = $(BMTOA_CFLAGS)
+bmtoa_LDADD = $(BMTOA_LIBS)
+bmtoa_SOURCES = \
+ bmtoa.c
+
+# atobm
+
+atobm_CFLAGS = $(ATOBM_CFLAGS)
+atobm_LDADD = $(ATOBM_LDADD)
+atobm_SOURCES = \
+ atobm.c
+
+# mans
+
+dist_man_MANS = \
+ bitmap.man
+
+
+# app default files
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+APPDEFAULTFILES = \
+ Bitmap-color \
+ Bitmap
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+
+EXTRA_DIST = $(foreach X, $(APPDEFAULTFILES), $(X).ad)
+CLEANFILES = $(APPDEFAULTFILES)
+
+# bitmaps
+
+bitmapdir = $(includedir)/X11/bitmaps
+
+dist_bitmap_DATA = \
+ Dashes \
+ Down \
+ Excl \
+ FlipHoriz \
+ FlipVert \
+ Fold \
+ Left \
+ Right \
+ RotateLeft \
+ RotateRight \
+ Stipple \
+ Term \
+ Up