summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-27 21:35:04 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-27 21:35:04 +0000
commit349b2847900798cacdfe358eb8eb4773106657e8 (patch)
tree2a898a2530eea0df0c2be94fabad3e8201e31765 /Makefile.am
parent9391b5d706fe66ac05cb3af1fd0263eed13776c8 (diff)
- Fix string test in lib/Xaw/xaw.m4
- Xaw/Xaw7/Makefile.am: add -DXAW7 - add build system for editres
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5dcf588
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,62 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = editres
+
+editres_CFLAGS = $(DEP_CFLAGS)
+editres_LDADD = $(DEP_LIBS)
+
+editres_SOURCES = \
+ actions.c \
+ comm.c \
+ config.h \
+ editres.c \
+ editresP.h \
+ geometry.c \
+ handler.c \
+ setvalues.c \
+ svpopup.c \
+ utils.c \
+ widgets.c \
+ wtree.c
+
+dist_man_MANS = \
+ editres.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+EXTRA_DIST = \
+ Edit-col.ad \
+ Editres.ad
+
+APPDEFAULTFILES = \
+ Edit-col \
+ Editres
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+CLEANFILES = $(APPDEFAULTFILES)
+