summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-01-23 16:57:59 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-01-23 16:57:59 -0800
commitd134cf4e83beccea282c49d1768e4ecf6b1ea52e (patch)
treeea1cfe2845eeda7a4a6a40a0f8eecf4969af4151 /Makefile.am
parentf8e170f16e591f349482ebfe166a639f60b78a19 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e4d944f..411e703 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,3 @@
-# $Id$
#
# Copyright 2005 Red Hat, Inc.
#
@@ -49,7 +48,7 @@ APPDEFAULTFILES = \
Editres-color \
Editres
-EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad)
+EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) ChangeLog autogen.sh
SUFFIXES = .ad
@@ -59,7 +58,12 @@ SUFFIXES = .ad
appdefault_DATA = $(APPDEFAULTFILES)
CLEANFILES = $(APPDEFAULTFILES)
+MAINTAINERCLEANFILES=ChangeLog
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
appmandir = $(APP_MAN_DIR)