summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-06-02 11:35:43 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-06-02 11:35:43 -0700
commit43c19175385f98894c1633ed57ec6778e17a38a6 (patch)
tree106eae499b079accde836a99283f4f8e86daf9f7 /Makefile.am
parent2b838dbd23f2ae2a3ff479003b13e03563624009 (diff)
Clear 208 out of 210 -Wdiscarded-qualifiers warnings from gcc 7.3
Depends on building with a libXt version that defines String as a const char * if _CONST_X_STRING is defined. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 874e0f7..b203753 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,7 @@ SUBDIRS = man
bin_PROGRAMS = editres
AM_CFLAGS = $(CWARNFLAGS) $(EDITRES_CFLAGS)
+AM_CPPFLAGS = -D_CONST_X_STRING
editres_LDADD = $(EDITRES_LIBS)
editres_SOURCES = \