summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 19:46:18 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 19:46:18 +0000
commitb209b9a7f683c10a77ed2e03da79b7ac1abc4844 (patch)
tree73af552e3936bfe86f450904aaa4752750b81c47 /Makefile.am
parente8571878caa5d35f712e158a45391584da3d5e47 (diff)
Build system for fonttosfnt
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..99a9ac5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,42 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = fonttosfnt
+
+fonttosfnt_CFLAGS = $(DEP_CFLAGS) -DXVENDORNAME=\"X.org\ Foundation\" -DXVENDORNAMESHORT=\"X.org\"
+fonttosfnt_LDADD = $(DEP_LIBS) -lm
+
+fonttosfnt_SOURCES = \
+ fonttosfnt.c \
+ fonttosfnt.h \
+ read.c \
+ struct.c \
+ util.c \
+ write.c
+
+if NEED_SETENV
+fonttosfnt_SOURCES += env.c
+fonttosfnt_CFLAGS += -DNEED_SETENV
+endif
+
+dist_man_MANS = \
+ fonttosfnt.man
+