summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@reactor.herrb.com>2006-07-16 10:43:55 +0200
committerMatthieu Herrb <matthieu@reactor.herrb.com>2006-07-16 10:43:55 +0200
commitb30bd59af161fc0907d497101f10705c7b575008 (patch)
treeef2676e748db11736c19afd5e7d41d2cbb581be3 /Makefile.am
parentf5d7f68599f4d2ec86df0910f8c823b8feabc6db (diff)
Replace ChangeLog with a auto-generated git-log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ff32891..bace99c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,8 +45,8 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
-CLEANFILES = $(appman_DATA)
+EXTRA_DIST = $(appman_PRE) ChangeLog
+CLEANFILES = $(appman_DATA) ChangeLog
SED = sed
@@ -71,3 +71,10 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log > ChangeLog
+
+dist-hook: ChangeLog