summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:36:59 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:36:59 -0500
commitf27374f843995264e0f2c7c3e2728811bcbd0f29 (patch)
tree52b19fb9ee72777bfb81b7db27d551a7da71b772 /Makefile.am
parent50fc125ad63e62879ceb6aab70dea5b6088d15bd (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d7a613..d543e74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,3 +65,13 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog