summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-07-02 21:42:05 +0000
committerKevin E Martin <kem@kem.org>2005-07-02 21:42:05 +0000
commit30441ee004c0c23d42b76af09e58314aa2218fa3 (patch)
treea91f0c11a557a8560749ad4289336424367daefd /Makefile.am
parent3748201b7bbae3a0c0d20001651430245beab335 (diff)
Add build system for bdftopcf, mkfontdir and mkfontscale
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..8689fd9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,37 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software
+# and its documentation for any purpose is hereby granted without fee,
+# provided that the above copyright notice appear in all copies and that
+# both that copyright notice and this permission notice appear in
+# supporting documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software
+# without specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any
+# purpose. It is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF
+# USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR
+# OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = mkfontscale
+
+mkfontscale_CFLAGS = @DEP_CFLAGS@
+mkfontscale_LDADD = @DEP_LIBS@
+
+mkfontscale_SOURCES = \
+ data.h \
+ hash.c \
+ hash.h \
+ ident.c \
+ ident.h \
+ list.c \
+ list.h \
+ mkfontscale.c
+
+dist_man1_MANS = mkfontscale.man