summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-08 18:07:43 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-08 18:07:43 -0700
commit08fa8d42ec875802bbe34291b087abdc559f183e (patch)
treee328d47aa61bf26475d63abb19ce797e24ea4f2c /Makefile.am
parent36288deba168dd2ca94630ffeab69f85461e33f8 (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c2bebf..4a7bb2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ bin_PROGRAMS = setxkbmap
XKBCONFIGROOT=@XKBCONFIGROOT@
-AM_CFLAGS = $(SETXKBMAP_CFLAGS) \
+AM_CFLAGS = $(CWARNFLAGS) $(SETXKBMAP_CFLAGS) \
-D__XKBDEFRULES__='"xorg"' \
-DDFLT_XKB_CONFIG_ROOT=\"$(XKBCONFIGROOT)\"
setxkbmap_LDADD = $(SETXKBMAP_LIBS)
@@ -71,7 +71,7 @@ MAN_SUBSTS = \
SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
- sed $(MAN_SUBSTS) < $< > $@
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
if LINT
ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \