summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-04-16 20:34:31 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-04-16 20:34:31 -0700
commit2d43b8fa9b21bcf9f5c289ab1afba3e73c42f661 (patch)
tree3d503f3531c72f32703c2cba851720af0c85cf36 /Makefile.am
parentf7007821434313df1dc848a1e547922f65d4c7d5 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2adbd44..318b801 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,9 +38,14 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog
CLEANFILES = $(appman_DATA)
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
SED = sed
# Strings to replace in man pages