summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-10-20 22:17:26 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-10-20 22:17:26 +0000
commitee92bd69fbe2b31629a1f9d87d464113ca8f0721 (patch)
treef1f73673fe9d82fa63f20feb4a6da1ac761ff9b8 /Makefile.am
parent7909f46a7ba31944be57b1574f70da82d8bfd385 (diff)
Bug #4830 <https://bugs.freedesktop.org/show_bug.cgi?id=4830> Set
DFLT_XKB_CONFIG_ROOT instead of using hard-coded default.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 74ecbd5..6ad3291 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,9 @@
bin_PROGRAMS = setxkbmap
-setxkbmap_CFLAGS = $(SETXKBMAP_CFLAGS) -D__XKBDEFRULES__='"xorg"'
+setxkbmap_CFLAGS = $(SETXKBMAP_CFLAGS) \
+ -D__XKBDEFRULES__='"xorg"' \
+ -DDFLT_XKB_CONFIG_ROOT='"$(datadir)/X11/xkb"'
setxkbmap_LDADD = $(SETXKBMAP_LIBS)
setxkbmap_SOURCES = \