summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f2b876..226d448 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,9 +21,11 @@
bin_PROGRAMS = setxkbmap
+XKBCONFIGROOT=@XKBCONFIGROOT@
+
setxkbmap_CFLAGS = $(SETXKBMAP_CFLAGS) \
-D__XKBDEFRULES__='"xorg"' \
- -DDFLT_XKB_CONFIG_ROOT='"$(datadir)/X11/xkb"'
+ -DDFLT_XKB_CONFIG_ROOT=\"$(XKBCONFIGROOT)\"
setxkbmap_LDADD = $(SETXKBMAP_LIBS)
setxkbmap_SOURCES = \