summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e7052c..7dc1db7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,13 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
+AC_ARG_WITH(xkb-config-root,
+ AC_HELP_STRING([--with-xkb-config-root=<paths>],
+ [Set default XKB config root (default: ${datadir}/X11/xkb)]),
+ [XKBCONFIGROOT="$withval"],
+ [XKBCONFIGROOT=${datadir}/X11/xkb])
+AC_SUBST([XKBCONFIGROOT])
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(SETXKBMAP, xkbfile x11)
AC_SUBST(SETXKBMAP_CFLAGS)