summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:07 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:07 -0500
commitf0543e7ff17f6e8aefbd6cc003d0679a706a8535 (patch)
treef19a83fe6b4eee2637235055c91deaba28fb40d0 /Makefile.am
parent44d51a2bc7d1e2fc5fcd3f729b6f0ca6e62e1f00 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d1b0a22..9d53635 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,3 +22,13 @@
SUBDIRS = src man
EXTRA_DIST = sample-twmrc/jim.twmrc sample-twmrc/keith.twmrc sample-twmrc/lemke.twmrc
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog