summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-06-04 17:09:18 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-06-04 19:26:47 -0400
commit29a157f7f181ac02c88537032dbcca29880c3068 (patch)
tree3631d085b73bd37e07825c3b88bbba2d30b2b7da /configure.ac
parentd0da74f035fd3595b5ddfb6ded29bdc5f9666ceb (diff)
config: add check for yacc to insure it is installed #27973
Unlike other macros AC_PROG_YACC sets the YACC variable to "yacc" as a last resort, even if no programs have been found. Improve error checking by issuing an error message if yacc is not found. The module cannot build anyway. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c888e62..726d457 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,8 @@ XORG_DEFAULT_OPTIONS
AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_YACC
+AC_PATH_PROG([YACC_INST], $YACC)
+test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])
AC_PROG_LEX
AC_CHECK_FUNC([mkstemp],