summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>2019-07-16 20:40:50 -0400
committerThomas E. Dickey <dickey@invisible-island.net>2019-07-16 20:40:50 -0400
commit98ff71aff13d9e35bb2436a15ea3fd38ea2fffa4 (patch)
tree31fac64d563b0c07d9b38b6ea116fde5c2db6fd6 /configure.ac
parent9f3f818068ba54ab2b46142e73100ef10a0bda0b (diff)
issue 2: twm doesn't handle RandR screen size changes
patch submitted by Preston Crow modified to check if xrandr development header/library is available Signed-off-by: Thomas E. Dickey <dickey@invisible-island.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7b6643b..2cb0a6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,11 @@ AC_PROG_LEX
AC_CHECK_FUNCS([mkstemp])
# Checks for pkg-config packages
-PKG_CHECK_MODULES(TWM, x11 xext xt xmu ice sm xproto >= 7.0.17)
+PKG_CHECK_MODULES([TWM], [x11 xext xt xmu ice sm xproto >= 7.0.17])
+PKG_CHECK_MODULES([XRANDR], [xrandr], [have_xrandr=yes], [have_xrandr=no])
+if test "$have_xrandr" = yes; then
+ AC_DEFINE([HAVE_XRANDR], [1], [Define to 1 if you have the xrandr headers/libraries])
+fi
AC_CONFIG_FILES([Makefile
src/Makefile