summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-07-16 21:59:14 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-07-16 21:59:14 +0000
commit63e81296232ec5fdd6529a7d5d4342186bbec2f8 (patch)
tree49e7359b2ddf5676c18d50510cab041032911676 /configure.ac
parent2e6a393e7b0f02e8f58a3005411ae22488965e28 (diff)
Define HAS_MKSTEMP if mkstemp() is present (needed for improved protection
against tempfile race conditions in many places)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0aef20f..a5f84af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,9 @@ AC_PROG_INSTALL
AC_PROG_YACC
AC_PROG_LEX
+AC_CHECK_FUNC([mkstemp],
+ AC_DEFINE(HAS_MKSTEMP,1,[Define to 1 if you have the `mkstemp' function.]))
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(DEP, x11 xt xmu)
AC_SUBST(DEP_CFLAGS)