summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>2019-07-16 20:40:50 -0400
committerThomas E. Dickey <dickey@invisible-island.net>2019-07-16 20:40:50 -0400
commit98ff71aff13d9e35bb2436a15ea3fd38ea2fffa4 (patch)
tree31fac64d563b0c07d9b38b6ea116fde5c2db6fd6 /src/Makefile.am
parent9f3f818068ba54ab2b46142e73100ef10a0bda0b (diff)
issue 2: twm doesn't handle RandR screen size changes
patch submitted by Preston Crow modified to check if xrandr development header/library is available Signed-off-by: Thomas E. Dickey <dickey@invisible-island.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1f46e09..4bafe55 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,8 +32,8 @@ AM_CPPFLAGS = \
-DXORG_RELEASE=\"Release\ $(VERSION)\" \
-DSYSTEM_INIT_FILE=\"${rcdir}/system.twmrc\"
-AM_CFLAGS = $(TWM_CFLAGS)
-twm_LDADD = $(TWM_LIBS)
+AM_CFLAGS = $(TWM_CFLAGS) $(XRANDR_CFLAGS)
+twm_LDADD = $(TWM_LIBS) $(XRANDR_LIBS)
twm_SOURCES = \
add_window.c \