summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2011-05-10 15:35:51 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-05-11 20:34:23 -0700
commit0f1ccd0b3409ab9b9fce1256fc59ad9bbe69a349 (patch)
tree2d292d2fcff0298aca442a33886507743f29f57b /src/Makefile.am
parent75dd868133c5c12daa946468e7250d174f842281 (diff)
Fix: menus.c:2374: warning: implicit declaration of function `putenv`
Ensure _GNU_SOURCE is defined on Linux builds before including <stdlib.h> so the prototype is exposed in the header properly. https://bugs.freedesktop.org/show_bug.cgi?id=32696 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cb6f615..cfd0b44 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -27,7 +27,7 @@ bin_PROGRAMS = twm
rcdir = ${datadir}/X11/twm
dist_rc_DATA = system.twmrc
-AM_CFLAGS = $(TWM_CFLAGS) -DXVENDORNAME=\"The\ X.Org\ Foundation\" -DXORG_RELEASE=\"Release\ $(VERSION)\" -D_BSD_SOURCE
+AM_CFLAGS = $(TWM_CFLAGS) -DXVENDORNAME=\"The\ X.Org\ Foundation\" -DXORG_RELEASE=\"Release\ $(VERSION)\"
AM_CFLAGS += -DSYSTEM_INIT_FILE=\"${datadir}/X11/twm/system.twmrc\"
twm_LDADD = $(TWM_LIBS)