summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-19 18:40:18 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-19 18:40:18 -0200
commit8f1476657baae54dcca998c01bd4ffe0233a6ba2 (patch)
tree75967bf455d06752eb7f047d547db4f0e7dad331 /configure.ac
parent8906fd92f85710d6d7eceac2fb5955e8c56eadcd (diff)
Ansification and compile warning fixes.
This also uses XORG_CHANGELOG and XORG_CWARNFLAGS, corrects make distcheck and all gcc 4.3 and sparse warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3593007..840a4a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,21 +26,32 @@ AC_INIT(viewres,[1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xor
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
-PKG_CHECK_MODULES(VIEWRES, xaw7)
+XORG_CWARNFLAGS
+PKG_CHECK_MODULES(VIEWRES, xaw7)
+VIEWRES_CFLAGS="$CWARNFLAGS $VIEWRES_CFLAGS"
AC_SUBST(VIEWRES_CFLAGS)
AC_SUBST(VIEWRES_LIBS)
PKG_CHECK_MODULES(APPDEFS, xt)
-appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+AC_ARG_WITH(appdefaultdir,
+ AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ [specify directory for app-defaults files (default is autodetected)]),
+ [appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile])