summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 20:41:01 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 20:41:01 +0000
commit68ebb5b755791822c2f1d9f9659c2ee94bb63f1c (patch)
treecbf34974a9dabf3569bfa376d4c7401cfe84307b /Makefile.am
parent21b7ff0b54fcf28e933738aaaedf5aef46880717 (diff)
Add x11perf build system Add some x11perf shell script to symlink.sh
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..11decc6
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,65 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = x11perf
+
+bin_SCRIPTS = x11perfcomp
+
+LIBPATH = $(libdir)/X11/x11perfcomp
+
+x11perfcompdir = $(LIBPATH)
+dist_x11perfcomp_SCRIPTS = fillblnk.sh perfboth.sh perfratio.sh Xmark.sh
+
+x11perf_CFLAGS = $(DEP_CFLAGS)
+x11perf_LDADD = $(DEP_LIBS) -lm
+
+x11perf_SOURCES = \
+ bitmaps.c \
+ bitmaps.h \
+ do_arcs.c \
+ do_blt.c \
+ do_complex.c \
+ do_dots.c \
+ do_lines.c \
+ do_movewin.c \
+ do_rects.c \
+ do_segs.c \
+ do_simple.c \
+ do_tests.c \
+ do_text.c \
+ do_traps.c \
+ do_tris.c \
+ do_valgc.c \
+ do_windows.c \
+ x11perf.c \
+ x11perf.h
+
+dist_man_MANS = \
+ x11pcomp.man \
+ x11perf.man \
+ Xmark.man
+
+x11perfcomp: x11pcomp.cpp
+ $(SED) s/LIBPATH/`echo $(LIBPATH) | sed -e s/\\\\//\\\\\\\\\\\\\//g`/ < $< | \
+ $(SED) s/XCOMM/\#/ > $@
+
+
+CLEANFILES = $(bin_SCRIPTS) x11perfcomp