summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 20:41:01 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 20:41:01 +0000
commit68ebb5b755791822c2f1d9f9659c2ee94bb63f1c (patch)
treecbf34974a9dabf3569bfa376d4c7401cfe84307b /configure.ac
parent21b7ff0b54fcf28e933738aaaedf5aef46880717 (diff)
Add x11perf build system Add some x11perf shell script to symlink.sh
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 44 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3ded10b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,44 @@
+
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(x11perf,[7.0], [xorg@freedestkop.org],x11perf)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+AC_PATH_PROG(SED,sed)
+if [[ -z $SED ]] ; then
+ AC_MSG_ERROR([sed is needed to build x11perf])
+fi
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(DEP, x11 xmu)
+AC_SUBST(DEP_CFLAGS)
+AC_SUBST(DEP_LIBS)
+
+AC_OUTPUT([Makefile])