summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-21 11:15:50 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-21 11:15:50 -0700
commit5ee182a964d0ba16315935ec9bfd91779ed4a2a1 (patch)
tree23a9866ff186c5c7258268bc0d93e746a49fca71 /Makefile.am
parent3c9230230e88f6421ea3549f813eabceb4120734 (diff)
Replace static changelog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f618cd9..aa0fd9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,10 +51,18 @@ SUFFIXES = .ad
appdefault_DATA = $(APPDEFAULTFILES)
-EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad)
+EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) ChangeLog autogen.sh
CLEANFILES = $(APPDEFAULTFILES)
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
appmandir = $(APP_MAN_DIR)