summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:43 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:43 +0000
commit203bc6e49653660050a874508da2c57e089c3c54 (patch)
treefb84eb9773a3150d93334e4bb134f9e0f2eb5dc3 /Makefile.am
parente70773cb5c4269627e0d8750f7852ed865fd8eaf (diff)
Use sed to fill in variables in man page
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f7a3f1..a17e70b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ xcalc_SOURCES = \
xcalc.c \
xcalc.h
-dist_man1_MANS = \
+appman_SOURCES = \
xcalc.man
# App default files (*.ad)
@@ -55,3 +55,34 @@ EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad)
CLEANFILES = $(APPDEFAULTFILES)
+
+appmandir = $(mandir)/man$(APP_MAN_SUFFIX)
+
+appman_DATA = $(appman_SOURCES:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST += $(appman_SOURCES)
+CLEANFILES += $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES += .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@