summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 23:12:07 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 23:12:07 +0000
commit392f5dd1907a5110c89b308ef51122b39b23dde5 (patch)
tree8b223dfbb4b8b61802c16509180dc2faa95885ab /Makefile.am
parenta72c79567a4f550dfafb532b03be79339c5a4a30 (diff)
Build system for Xcalc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3661fa2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,55 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xcalc
+
+xcalc_CFLAGS = $(DEP_CFLAGS)
+xcalc_LDADD = $(DEP_LIBS) -lm
+
+xcalc_SOURCES = \
+ actions.c \
+ actions.h \
+ math.c \
+ xcalc.c \
+ xcalc.h
+
+dist_man_MANS = \
+ xcalc.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ XCalc \
+ XCalc-col
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad)
+
+CLEANFILES = $(APPDEFAULTFILES)
+