summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-13 16:26:42 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-13 16:26:42 -0200
commit82d76c4efcae92709aa07ec9e653f73076f43ebf (patch)
treef2e47733c95115ff34c0d0adf82b80c6d6f93316 /configure.ac
parent48663cb8af72ea5e0528a341a7dc8865aa84fad2 (diff)
Ansification and compile warning fixes.
This also uses XORG_CHANGELOG and XORG_CWARNFLAGS, corrects make distcheck and all gcc 4.3 and sparse warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 17e9c8e..4b6d07b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,11 +26,17 @@ AC_INIT(xclock,[1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
+XORG_CWARNFLAGS
+
AC_CHECK_FUNCS([strlcpy getpid])
AC_SEARCH_LIBS([iconv], [iconv],
@@ -39,7 +45,7 @@ AC_SEARCH_LIBS([iconv], [iconv],
dnl Required dependencies
PKG_CHECK_MODULES(XCLOCK_X11, x11)
PKG_CHECK_MODULES(XAW, xaw7)
-XCLOCK_CFLAGS="$XCLOCK_X11_CFLAGS $XAW_CFLAGS"
+XCLOCK_CFLAGS="$CWARNFLAGS $XCLOCK_X11_CFLAGS $XAW_CFLAGS"
XCLOCK_LIBS="$XCLOCK_X11_LIBS $XAW_LIBS"
dnl Optional dependencies
@@ -65,10 +71,15 @@ AC_SUBST(XCLOCK_CFLAGS)
AC_SUBST(XCLOCK_LIBS)
PKG_CHECK_MODULES(APPDEFS, xt)
-appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+AC_ARG_WITH(appdefaultdir,
+ AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ [specify directory for app-defaults files (default is autodetected)]),
+ [appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile])