summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-03-19 19:09:27 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-03-19 19:09:27 -0700
commit752b793aa03b67eeff6b01c7f0bdb729f00bd49b (patch)
tree69667fa7d9fdb9e44219330dd85ab75941ccd5a6 /Makefile.am
parentd66b154dce42319f73f4b0773e44c59c9cf9d7a6 (diff)
Add support for checking sources with sparse/lint/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e45c79a..cdf2bac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -92,3 +92,11 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(AM_CFLAGS) $(xdpyinfo_SOURCES)
+endif LINT