summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-17 16:26:04 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-17 16:26:04 -0700
commitf930da05f9d0af42d2daa026b1e99a9e5f0ff4a7 (patch)
tree5a6e3ffd9cd12f55ff24827adff5d71456ccc893 /Makefile.am
parent1d8078119bdfc51e656ca4eb0e5ad122f334cd88 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5976e62..1d79232 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,8 +34,14 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog autogen.sh
CLEANFILES = $(appman_DATA)
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
SED = sed