summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-08-29 11:07:33 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-08-29 11:07:33 +0000
commitae8b217d70907921d4df62a17c7f78cdb99474fe (patch)
tree4f46ecb0d546208353ea5c9ba6ef4f335b7d2bed /Makefile.am
parentd5234bf9acf43337c35c6b83d003a8a5aab9b61b (diff)
Adding xdriinfo build system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0688eb7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xdriinfo
+
+xdriinfo_CFLAGS = $(XDRIINFO_CFLAGS)
+# mesa should really use pkg-config ...
+xdriinfo_LDADD = $(XDRIINFO_LIBS) -lGL
+
+xdriinfo_SOURCES = \
+ xdriinfo.c
+
+dist_man1_MANS = \
+ xdriinfo.man