summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2014-09-09 20:26:15 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2014-09-09 20:26:15 -0700
commit4c63319d249cb796b735ec56904c088c56a5171f (patch)
treef00f62f8eedca10ef7071f5601a0ead8f2d43745 /configure.ac
parent9f0f4a2c5495eec2d81a4381fb962fad93b2ddde (diff)
Check for pagesize options via autoconf instead of per-platform #ifdefs
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9df9ecc..720a7ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,9 @@ AC_ARG_WITH(lispdir, AS_HELP_STRING([--with-lispdir=PATH],
LISPDIR=$lispdir
AC_SUBST(LISPDIR)
+AC_CHECK_DECLS([_SC_PAGESIZE])
+AC_CHECK_FUNCS([getpagesize])
+
AC_CHECK_FUNC(realpath, [], [have_realpath=yes])
AM_CONDITIONAL(NEED_REALPATH, test x$have_realpath = xyes)
AC_CHECK_FUNC(strcasecmp, [], [have_strcasecmp=yes])