summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 15:51:06 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 15:51:06 -0500
commitd82fb133b9cd4d3284db553a0afdd530b466073e (patch)
treed5065da401ecb756de2a7091a7eb6b13da91533b /Makefile.am
parent29a316c91b55a0ca193c9e902491f2ae78f33b76 (diff)
Add missing PHONY line for automatic ChangeLog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a3e84..3af1bda 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,6 +63,8 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+.PHONY: ChangeLog
+
ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog