summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-12 18:36:45 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-12 18:36:45 -0700
commit5c92c37b733db62d2504d6d93f5b5da0658b06b2 (patch)
tree18c15e935663015edb07e3f35fba71e17049992f /configure.ac
parent40bcf74b066c3b0347e5bc735bcf9a670af1b8c2 (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 3ff1144..f4b2ddc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,20 +27,19 @@ AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-# Require xorg-macros: XORG_RELEASE_VERSION XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AC_PROG_CC
AC_PROG_INSTALL
+XORG_DEFAULT_OPTIONS
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(XEV, x11)
AC_SUBST(XEV_CFLAGS)
AC_SUBST(XEV_LIBS)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])