summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDylan Simon <dylan@dylex.net>2009-09-27 14:44:35 -0400
committerJames Cloos <cloos@jhcloos.com>2009-09-27 14:44:35 -0400
commit5e825a140f4022b88dd7a1a20a9a01b653f1a95c (patch)
tree36a25fc8b364053ea0c126013eabaa7cb69075b8 /configure.ac
parentdbb8401026c421d64a2962e6ac6eb900f6dc141e (diff)
Add xrender support
Optionally draw all components (except shape) with xrender. Enabled by default. Xlib rendering can be restored by "configure --without-xrender" or "xeyes +render". Signed-off-by: Dylan Simon <dylan@dylex.net> Signed-off-by: James Cloos <cloos@jhcloos.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 188d2ca..d1fb5a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,15 @@ XEYES_CFLAGS="$CWARNFLAGS $XEYES_CFLAGS"
AC_SUBST(XEYES_CFLAGS)
AC_SUBST(XEYES_LIBS)
+dnl Optional dependencies
+AC_ARG_WITH(xrender, AC_HELP_STRING([--with-xrender],[Use Xrender for rendering (Default is YES)]),use_xrender="$withval",use_xrender="try")
+if test x$use_xrender != xno ; then
+ PKG_CHECK_MODULES(XRENDER, [xrender >= 0.4])
+ XEYES_CFLAGS="$XEYES_CFLAGS $XRENDER_CFLAGS"
+ XEYES_LIBS="$XEYES_LIBS $XRENDER_LIBS"
+ AC_DEFINE([XRENDER],1,[Define to use X Render Extension])
+fi
+
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
XORG_CHANGELOG