summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2010-01-15 22:20:56 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2010-01-29 22:39:19 -0800
commit12a1392fc96e32ed6d55208a2a7fc040617a9cb7 (patch)
tree51f01517b3aed8af3773e0aad43603152f73a2b1 /Makefile.am
parentb83ec6e3a79e30b8a7a3947679221ad76441b27f (diff)
Integrate gettext support with autotools build system
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e8a16a3..26b8a83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,3 +85,12 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog INSTALL
+
+if USE_GETTEXT
+noinst_DATA = xfd.po
+
+xfd.po: $(xfd_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -d xfd -n $(xfd_SOURCES:%=$(srcdir)/%)
+
+CLEANFILES += xfd.po
+endif