summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-12-07 13:35:45 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-12-10 13:22:25 -0500
commit677df8dfd37f1018b38b4c8653bde35766d895bc (patch)
tree39f4ef81522ebff0639793e93507a9e1a8490a11 /Makefile.am
parent74d5bc691b3a6dcc2dee99ed8b3c15d781b93843 (diff)
Use the Automake recommended alternative to AX_DEFINE_DIR
DATADIR, like any installation variable, is not known at configure time. This is by design to allow setting the variable at make time. The AX_DEFINE_DIR macro worked around this design and consequently cancelled an Automake feature. The alternative method suggested by Automake ends up being simpler while providing the same result as AX_DEFINE_DIR but without cancelling any feature. It is used in the xserver for the parser and in xquartz. The AX_DEFINE_DIR macro has been removed from the Autoconf Archive. There are no official providers for this macro anymore. Separate pre-processor from compiler flags. XFD_CFLAGS and CWARNFLAGS may contain compiler flags. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5052217..b179b4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,11 +22,10 @@
SUBDIRS = man
bin_PROGRAMS = xfd
-AM_CFLAGS = $(XFD_CFLAGS) $(CWARNFLAGS) -DXRENDER -D_BSD_SOURCE
+AM_CPPFLAGS = -DXRENDER -D_BSD_SOURCE -DLOCALEDIR=\"$(LOCALEDIR)\"
+AM_CFLAGS = $(XFD_CFLAGS) $(CWARNFLAGS)
xfd_LDADD = $(XFD_LIBS)
-ACLOCAL_AMFLAGS = -I m4
-
xfd_SOURCES = \
grid.c \
grid.h \