summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 15:14:08 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 15:14:08 +0000
commit5309f3af0daaf8292ad4fbdd8a7c1c66dc20a178 (patch)
treee88da29aa521d6ba24d4b494263dbd43a91c0f36 /Makefile.am
parent861dfbf4919bdd2358c0b22e6c3eea116c6ac9c1 (diff)
Build system for xfd
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..95a6e46
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,53 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xfd
+
+xfd_CFLAGS = $(DEP_CFLAGS) -DXRENDER
+xfd_LDADD = $(DEP_LIBS)
+
+xfd_SOURCES = \
+ grid.c \
+ grid.h \
+ gridP.h \
+ xfd.c
+
+dist_man_MANS = \
+ xfd.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ Xfd
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad)
+
+CLEANFILES = $(APPDEFAULTFILES)
+