summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-02-01 10:44:12 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-02-01 10:44:12 -0800
commit5c43b433c0f3042f24f41eb66d3453c72edd3698 (patch)
treef3cb2fb7b90de413702182bde6c44db6c4c68c9b /Makefile.am
parenta109dc6867135b8dcdb4a32d016dba96fc42b1fa (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e3bbe50..07d2324 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,7 +48,7 @@ SUFFIXES = .ad
appdefault_DATA = $(APPDEFAULTFILES)
-EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad)
+EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) ChangeLog autogen.sh
CLEANFILES = $(APPDEFAULTFILES)
@@ -83,3 +83,10 @@ SUFFIXES += .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog