summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-04-03 15:48:25 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-04-03 15:48:25 -0700
commit3ef81a443a264c48f606dfedd47eb160822457fa (patch)
tree0734e4bf7a8f847d0228c368f0dd236185785451 /configure.ac
parentbe2a75ec654722b282c9e2fac2b73a4dba9f50d0 (diff)
mark Quit() & QuitAction() as noreturn
Clears gcc warnings: xfontsel.c: In function ‘QuitAction’: xfontsel.c:1477:1: warning: function might be candidate for attribute ‘noreturn’ [-Wsuggest-attribute=noreturn] QuitAction(Widget w, XEvent *event, String *params, Cardinal *num_params) ^~~~~~~~~~ xfontsel.c: In function ‘Quit’: xfontsel.c:1392:6: warning: function might be candidate for attribute ‘noreturn’ [-Wsuggest-attribute=noreturn] void Quit(Widget w, XtPointer closure, XtPointer callData) ^~~~ Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85889d7..bf3ad81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,7 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-PKG_CHECK_MODULES(XFONTSEL, xaw7 xmu xt x11)
+PKG_CHECK_MODULES(XFONTSEL, xaw7 xmu xt x11 xproto >= 7.0.17)
PKG_CHECK_MODULES(APPDEFS, xt)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`