summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e62fd49..62e51c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,3 +53,14 @@ ChangeLog:
dist-hook: ChangeLog INSTALL
EXTRA_DIST = README.md
+
+if USE_GETTEXT
+AM_CPPFLAGS = -DLOCALEDIR='"$(LOCALEDIR)"'
+
+noinst_DATA = xfontsel.po
+
+xfontsel.po: $(xfontsel_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -d xfontsel -c -n $(xfontsel_SOURCES:%=$(srcdir)/%)
+
+CLEANFILES = xfontsel.po
+endif