summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-06 18:42:01 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-06 18:42:01 -0700
commit534c77b8a405fd178283e4fa8d7eb797b5966cbc (patch)
tree1781392df89ca4a2ebe569196069be0377a25d17 /Makefile.am
parenteff5594f8f68913db9ac60c9b38ec711823052ae (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4b9097..5a0b40f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,9 +35,19 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog
CLEANFILES = $(appman_DATA)
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
+
SED = sed
# Strings to replace in man pages