summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-13 15:55:19 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-13 15:55:19 -0200
commit04b994830dfebfed9311f1c3714620ebbdc1f75a (patch)
tree027b6643d7b0984a89302abd0ea2bb8f1387209b /Makefile.am
parentd662fac7b6541571ab9852f4e0290d48f0e97561 (diff)
Ansification and compile warning fixes.
This also uses XORG_CHANGELOG and XORG_CWARNFLAGS, corrects make distcheck and most gcc 4.3 and sparse warnings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4601ca0..55a7ec4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,6 @@ xgc_SOURCES = \
interpret.c \
lex.l \
main.c \
- main.h \
planemask.c \
record.c \
testfrac.c \
@@ -53,6 +52,8 @@ gram.h: gram.c
# App default files
+DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
+
appdefaultdir = @appdefaultdir@
dist_appdefault_DATA = \
@@ -106,6 +107,6 @@ MAINTAINERCLEANFILES += ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog