summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 21:11:37 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 21:11:37 +0000
commit07ed043059d5fc7e8d694f6814eb1ba63946d646 (patch)
tree5ab759ec22d3daff8ae124fbcc799fe9d6f2ebdc /Makefile.am
parentace744607cc888bafb3ba487a11785fd46b65818 (diff)
Add build system for xgc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0ddafc1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,75 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+AM_YFLAGS = -d
+
+bin_PROGRAMS = xgc
+
+xgc_CFLAGS = $(DEP_CFLAGS)
+xgc_LDADD = $(DEP_LIBS) -lm
+
+xgc_SOURCES = \
+ choice.c \
+ constants.h \
+ dashlist.c \
+ getfile.c \
+ gram.y \
+ interpret.c \
+ lex.l \
+ main.c \
+ main.h \
+ planemask.c \
+ record.c \
+ testfrac.c \
+ tests.c \
+ text.c \
+ xgc.h
+
+dist_man_MANS = \
+ xgc.man
+
+BUILT_SOURCES = gram.h
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ Xgc
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad) tile Bugs \
+ Written/FilledRects \
+ Written/Interface \
+ Written/Jim \
+ Written/Notes \
+ Written/Notes2 \
+ Written/Outline \
+ Written/Widget
+
+CLEANFILES = $(APPDEFAULTFILES)
+