summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2005-08-02 18:10:32 +0000
committerKeith Packard <keithp@keithp.com>2005-08-02 18:10:32 +0000
commitda90b92a612915f9d7053015025785e338ee7a0c (patch)
tree75a03e5595ad38fb5ad59396843224eabfdc9d92 /Makefile.am
parentdea36bb8cdeed1629110cbc407fdb18482d59651 (diff)
Mark generated files as BUILT_SOURCES and CLEANFILES to ensure they are
regenerated after 'make clean' and to make parallel builds work right.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e4374e1..580bbab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,9 @@ xgc_SOURCES = \
dist_man1_MANS = \
xgc.man
-BUILT_SOURCES = gram.h
+BUILT_SOURCES = gram.h gram.c lex.c
+
+gram.h: gram.c
# App default files (*.ad)
@@ -72,5 +74,5 @@ EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) tile Bugs \
Written/Outline \
Written/Widget
-CLEANFILES = $(APPDEFAULTFILES)
+CLEANFILES = $(APPDEFAULTFILES) $(BUILT_SOURCES)