summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c67a4f..07f36b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,3 +19,14 @@ ChangeLog:
dist-hook: ChangeLog INSTALL
EXTRA_DIST = README.md
+
+if USE_GETTEXT
+AM_CPPFLAGS = -DLOCALEDIR='"$(LOCALEDIR)"'
+
+noinst_DATA = xhost.po
+
+xhost.po: $(xhost_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -d xhost -n $(xhost_SOURCES:%=$(srcdir)/%)
+
+CLEANFILES = xhost.po
+endif